Yamaha Starbike Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hey guy's, Im new to the forum.
I bought my strat. in 2006 and still loving it. It has recently developed intermittent missing problems that my service guy isn't finding.When maintaining a cruising speed it starts missing as soon as you give it gas or decellerate it stops missing. A few years back I put on the PR big air kit, roadhouse slip on, and the power commander 3,w/o2 sensor off. I did most of that at the same time so I can't say which made the most impact. But the butt doesnt lie,there was quite a difference. It still runs strong between the missing. I recently changed the plugs and that didnt stop it. Springer suggested it may be too lean. Can the lean condition develope over time, wondering if having a Dyno might be the answer. Any ideas, Thanks.......
 

·
Registered
Joined
·
1,452 Posts
Just a question have you run any injector cleaner or top engine cleaner in it lately. If it is running lean it will miss. Carbon build up will make it run lean because the carbon soaks up the gas. It's possible you have a dribbling injector. Try some cleaner through the fuel system.Won't hurt anything if it doesn't work and if it does work it's a cheap fix. Just a suggestion.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
It only misses while maintainig cruising speed. I did use some injctor cleaner, and it seemed to almost stop the missing. When on a ride in Arizona a bike shop suggested trying it with Chevrons highest octane fuel, and said if that stops it then you know you have a fuel issue. It did seem to run better back to California. My bike shop said that was just coincidental. His latest guess is a fuel filter or fuel pump. He says the filter cannot be cleaned because it's inside the sealed fuel pump and you must buy a new pump. I think the pump is over $600.00. Is this correct? You cannot clean the fuel filter. Thanks for your help...
 

·
Registered
Joined
·
254 Posts
Hi Rick, many have had missing problems with the fuel management systems PC on there bikes. At least the ones I have heard complaints about, the rest love them. Anyway what I would do besides putting in fuel treatment and seeing if that cures. I don't have power commander on my bike , have done K&N filter, RoadHouse slip on and it runs great. But I still hit limiter every so often to keep carbon build up out(old Roadstar days what we did) and adding Marvels Mystery Oil to every few tanks of gas.

Ok long story short...lol... unhook PCIII, and see if it runs better. Most have found besides decel pops that the stock ECU runs good. And you will gain some fuel economy.

Ride Safe
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Thanks for the suggestion. I'm gonna get to it this weekend and dissconect the PC-3. That doggone work keeps getting in the way.
 
1 - 6 of 6 Posts
Top