Yamaha Starbike Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey all,

I just installed a set of Speedster Slashdowns and a DynoJet Power Commander 5 on my 950. The pipes sound great and the bike is running very well. Problem is, the engine light came on after installation and is showing diagnostic code 14. I'm not sure what the refers to and subsequently I'm not sure what to check.

Installing the Power Commander involved plugging inline to the fuel injector's and the throttle position sensor (TPS). I double checked all of the connections but everything looks fine. Also double checked the O2 sensor and connection. Again, looks fine.

The bike runs great. Seems to be a little hot with some slight popping on decel but could just be a slight exhaust leak or some fine tuning of the fuel map. I still need to check and retighten the pipes now that I have some short rides on it.

Anyone have any ideas / suggestions on what that error code refers to or what I should check to remedy the issue? PS, I've tried disconnecting the battery to clear the code in case it was just from the initial connection of the PC5 but it won't go out. Thanks in advance for any help!
 

·
Registered
Joined
·
1,531 Posts
Fault code

Stumarshel,

I could not find the fault codes for a 950. For my Stratoliner error code 14 is, "Cylinder 1 intake air sensor hose clogged or disconnected." Don't have any idea if they are the same. I will look around and see if I can find them.
Dave
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks Dave. At least that gives me a place to start. Maybe something got knocked loose while I was installing the PC5. I wasn't able to find codes for a 950 either. I appreciate you looking.
Stu
 

·
Registered
Joined
·
821 Posts
Error code "14" on the 950 is "Fuel Pump".
 

·
Registered
Joined
·
8 Posts
My check engin light came on yesterday while on the interstate approx 40 mil form home the is error code #24. The bike seem to be running normal the rest of the way to the house. Any help would be greatly appreciated.
 

·
Registered
Joined
·
821 Posts
My check engin light came on yesterday while on the interstate approx 40 mil form home the is error code #24. The bike seem to be running normal the rest of the way to the house. Any help would be greatly appreciated.
What model bike is it?
 

·
Registered
Joined
·
821 Posts
error code #24 is O2 sensor.
 

·
Registered
Joined
·
821 Posts
Well, I'm no mechanic, so I really can't say about that.
However I would suggest letting the dealer check it out, or maybe a different dealer than that one.
At least that way you can maybe get some better answers.
I have the V Star 950T service manual, that's where I get the
error codes from.
 

·
Registered
Joined
·
8 Posts
Thanks, I am makking an appointment to take it in for service today. Is there any way to reset the check engin light and where did you get the service manual, I have look on line, with no luck.

thanks again
 

·
Registered
Joined
·
40 Posts
manuels

Thanks, I am makking an appointment to take it in for service today. Is there any way to reset the check engin light and where did you get the service manual, I have look on line, with no luck.

thanks again
hi, i got a disc for my 950 star on usa ebay from repairpro manuels po box 51 yanceyville nc 27379, it was really cheap and excellent quality.john.
 

·
Registered
Joined
·
821 Posts
I'm not sure how to reset the check engine light, I didn't see anything about that in the manual, but I'm sure the dealer knows how.
I bought the hard copy manual thru my dealer, was about $100.00.
 

·
Registered
Joined
·
8 Posts
Got the my bike to the shop on sat. they reset the error code(24) "O2 sensor", I ask why it came on after removing the O2 sensor 3500 mil before they had no clue. 600 mil so far and it has not come back on. again thanks for the help.

Ride Safe
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top