Yamaha Starbike Forum banner
21 - 29 of 29 Posts

·
Registered
'18 SVTC
Joined
·
810 Posts
Getting quite a group of Okies gathering here....so I'll throw in that I'm an original Okie born in Bartlesville during the Eisenhower administration and family moved away towards the end of the Kennedy administration.
 

·
Administrator - "Loose Nut" - Bandera, Texas
2001 VS1100 Classic (sold), 2006 HD EG(totaled) 2006 Vulcan 900 and 2019 HD Freewheeler (current)
Joined
·
14,510 Posts
Getting quite a group of Okies gathering here....so I'll throw in that I'm an original Okie born in Bartlesville during the Eisenhower administration and family moved away towards the end of the Kennedy administration.
:unsure: Are you really that old? ;)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #24 ·
Alrighty! I picked it up Saturday and drove it home. It rides great and is really comfortable. I have got to clean it up and get the dust knocked off of it and then I will post some pictures. I have a couple of gremlin's I have to work out since it has sat for a while. The turn signals work but the indicator light on the speedo isn't working so I tried changing the bulbs etc with no success so I guess I will break out the test light and see if the bulb is getting any power. The weird thing is when the bike is in neutral and the turn switch is indicated the neutral light starts blinking lol. The other is that I had to order a new petcock because the only way to keep it from leaking is by keeping it won the reserve setting. Those are the only two things I have found so far so I am pretty happy. Not worried about the petcock but the turn signal speedo light issue I see being a pain in the but to track down. The eng, neutral and oil light all work just not the turn switch even after I switched all of the bulbs around. I got a book on order and am ready to start studying.
 

·
Premium Member
Joined
·
377 Posts
Alrighty! I picked it up Saturday and drove it home. It rides great and is really comfortable. I have got to clean it up and get the dust knocked off of it and then I will post some pictures. I have a couple of gremlin's I have to work out since it has sat for a while. The turn signals work but the indicator light on the speedo isn't working so I tried changing the bulbs etc with no success so I guess I will break out the test light and see if the bulb is getting any power. The weird thing is when the bike is in neutral and the turn switch is indicated the neutral light starts blinking lol. The other is that I had to order a new petcock because the only way to keep it from leaking is by keeping it won the reserve setting. Those are the only two things I have found so far so I am pretty happy. Not worried about the petcock but the turn signal speedo light issue I see being a pain in the but to track down. The eng, neutral and oil light all work just not the turn switch even after I switched all of the bulbs around. I got a book on order and am ready to start studying.
You could have saved yourself some money and downloaded the owners and service manuals on this site. Unless of course you prefer hard copies.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #26 ·
Yeah I'm still holding on to books lol. I can't help it. Plus they don't shatter when I drop it on the floor. But if they don't make it by this weekend I will be online looking it up. The vstar wiki looks like an amazing resource.
 

·
Premium Member
Joined
·
377 Posts
21 - 29 of 29 Posts
Top