Yamaha Starbike Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Sorry if this question has been posted before, I attempted a search, but didnt see anything....

While out trying to soak up all the ride time I can possibly get before Winter rears it's ugly head, I noticed the smell of oil burning, and a bit of smoke. So I pulled over, and it appears that I have a small leak coming out of the rear cylinder head cover. Obviously I'll look into getting new seals, but is there anything else I should look for while I'm in there, that could have possibly caused the seal to fail?

It doesnt look like it'll be too much trouble to take care of myself, just wondering if anything (other than age) would have caused the seal to fail?

Thanks in advance for any insight.


Guess it's worth mentioning...

2001 Vstar 1100 Custom
 

·
Registered
Joined
·
44 Posts
Discussion Starter #2
21 veiws and nothing? Curosity gotthe best of me, I went ahead and pulle the cover. It is infact a bad seal. The top side was fine, and still had the rubbery, squishy feal to it. The lower part was hard as a rock. So Ill be oredering some new seals this week. Meanwhile, I flipped the seal so that the better part was towards the bottom, where the oil would be resting,so that should at least let me get another decent ride in tomorrow on my day off.
 

·
Registered
Joined
·
231 Posts
Nice temporary solution!

In regards to the views and no posts. Many people probably read, but didn't know so didn't want to steer you wrong (well at least that is my excuse!).
 

·
Registered
Joined
·
44 Posts
Discussion Starter #4
Haha, no worries. Hopefully that 2nd post didnt come off as being arrogant, it was more of a lame attempt at comedy. Guess that's why I'm not a comedian.

I did find the gaskets at the local Yammy shop that had them in stock today, so I'll be installing them tomorrow if time allows. Should fix the issue
 
1 - 4 of 4 Posts
Top